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Part One of this Guide, available in the Digital Photography Tutor Members 
Bulletin Number 2 (July 2005), covered tips on how to plan for your digital 
photography trip and how to use your digital camera while you’re on vacation.  
This edition continues the Quick Guide to Vacation Photos with Part Two – 
Introduction to the Photoshop Elements 3.0 or 4.0 Organizer.  Here you’ll see an 
overview of the Photoshop Elements Organizer, how to get your photos into the 
Organizer, and how to arrange the Organizer thumbnails for maximum 
convenience and efficiency.   
 
This series will conclude in the next issue of the Digital Photography Tutor 
Members Bulletin with Quick Guide to Vacation Photos with Part Three – 
How to use the Photoshop Elements 3.0 or 4.0 Organizer to save, backup, 
rename, organize and index all your photos so that you’ll always be able to find 
the ones you want to adjust, share, and print. 
 
Because the Photoshop Elements 3.0 program for MAC does not include the new 
Elements Organizer module, these second and third parts of the Guide only apply 
to PCs running the Windows operating system.  (If you’re a MAC user, please 
periodically check the MAC USERS page on my website 
www.DigitalPhotographyTutor.com to learn the status of Adobe’s plans to 
eventually release an Elements 4 for MAC version.) 
 
I hope that you followed the advice in Part One of this Guide and brought back 
lots and lots of vacation photos.  Taking a many, many shots is how professional 
photographers are able to end up with a few great photos.  And now with your 
digital camera and your ability to apply the power of Photoshop Elements by 
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using the techniques from the Digital Photography Tutor, you can end up with 
some great vacation photos too. 
 
When the digital photography era began, we used to worry about whether digital 
cameras would be producing too many images for the typical user to manage.  
Now Photoshop Elements 3 and 4 for the PC have come to our rescue with the 
Organizer.  The vacation photos you bring home are no longer at risk of 
becoming too much of a good thing. 
 
I hope these tips will help you extend and share the joys of your vacation. 
 
 
 
Jerry Rabow 
  
 
 
 
 
  

Part Two: 
Introduction to the Photoshop Elements 

3.0/4.0 Organizer 
 
 
 

AFTER YOU RETURN HOME 
 
The key to handling your vacation photos for the Windows version of Elements 3 
or 4 is the new Elements Organizer.  This powerful program has so many 
features and capabilities that it’s hard to decide which step to do first.  But once 
you understand how Organizer works, you can adopt and regularly follow a 
logical workflow system and be able to accomplish so much with only minimum 
time and effort.  There’s a lot to cover for a program with as many features as 
Organizer, so I’ve split up my roadmap of the Organizer steps to take for your 
vacation photos into two portions.  This Part Two of the Quick Guide to 
Vacation Photos provides some crucial fundamental understandings of how 
Organizer works and how you should begin to work with it. 
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The new Organizer screen 

 
1. What is the Organizer? 
 
If you’re used to working with Photoshop Elements 2 (or perhaps a prior version 
of the full Photoshop program) you may remember trying to work with the File 
Browser function.  The Elements or Photoshop File Browser widows displayed 
thumbnails of graphics image files in a window that permitted moving through 
the folder structure and scrolling through the thumbnails for each folder to 
visually identify the image file you wanted to open.  The File Browser closely 
resembled the familiar My Computer Explorer widow, but it was automatically 
restricted to image file formats that were readable in Photoshop, including the 
Photoshop PSD format. 
 
My personal experience with both the Elements and the full Photoshop browser 
windows was that opening them up took forever, as they had to identify and 
create thumbnails for all the image files for each folder.  And that great delay 
was on a lucky day.  Many times attempting to use the File Browser would just 
lock up the program or my entire computer, forcing a reboot. 
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The old File Browser screen 

 
 
The new Elements Organizer would be a substantial improvement even if it did 
nothing more than create a workable version of an image browser.  Since 
Organizer uses its own pre-created thumbnail files, it works almost 
instantaneously.  But in addition to simply being a graphics file browser that 
works well, Organizer brings so many other important new features (detailed 
later in this Guide) that Elements treats Organizer essentially as a separate 
program within the overall Elements program.  So Elements 3 and 4 now 
structurally consist of two separate but integrated modules, the Editor (which is 
the current version of the previous Elements programs) and the new Organizer.  
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One potential point of confusion is 
that the Organizer (in its normal 
view, rather than the specialized 
Calendar View, called Date View”) 
is referred to in both modules as 
the as the Elements Photo 
Browser.  What’s confusing is that 
nal File Browser window 

(File>Browse Photos in Editor in Organizer, or File>Browse Folders in Editor, 
with its continuing Shift-Ctrl-O shortcut).  Since there are only a few rare 
circumstances where you’d need to use the old-fashioned File Browser, Ele
should have re-assigned the File Browser keyboard shortcut to the Organize
and also adopted a more distinctive name for what has now become essentially
the legacy File Browser function.  Organizer is the Browser you’ll be using. 
 

 

both modules still provide a link to the traditio

ments 
r, 

 

. Getting Photos Into the Elements Organizer2  

nce you have installed Elements 3 or 4 on your PC/Windows computer, 
ory 

se 

 
O
Elements will automatically add the photo images from your camera mem
card to your Organizer catalog when you place the card into your computer’s 
card reader or connect your camera to your computer.  Don’t use any image 
capture or transfer software that may have come with your camera for this; u
Organizer instead.  
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It’s important to understand just what Organizer does at this stage: 

• Card Reader: Organizer treats a camera card in a card reader as if it 
were a still in a camera connected to the computer.  And rather than 
actually connecting your camera to the computer, you may find it more 
convenient to use a separate card reader, especially for vacation photos 
when you’ve brought home several memory cards.  Note that your 
computer treats a card reader simply as a removable media drive, which is 
how the reader is described in My Computer, so if you have occasion to 
import or copy images without using Organizer’s “Get Photos” function, 
you can do so through the standard Windows Explorer drag and drop 
functions in My Computer. 

• Catalog: Organizer keeps the information about your photos in a 
structure it calls a catalog.   A catalog is not the same thing as a hard 
drive folder, and a catalog can include image files in several folders.  
Because the various Organizer functions, such as searching for keyword 
tags, will only operate in one catalog at any time, you’ll probably want to 
keep all of your photos in the single default catalog (“My Catalog”) initially 
created for you by Organizer.   

(Note that an Organizer catalog can’t be expanded infinitely without 
eventually slowing down computer processing time, but you may never 
reach this limit.  It’s been recommended that for most computer systems 
you won’t need to start a new catalog until you exceed a maximum 
catalog size of about 10,000 images.)  

 
• Image File: Organizer does not hold a full copy of a photo’s actual 

source file (the source file is a large file, typically one megabyte or more, 
containing all the image and related text information captured by your 
camera for any photo).  Instead, for each photo in its catalog Organizer 
creates and holds a lower resolution (but still surprisingly clear) thumbnail 
image together with the text information created by the camera (date, 
time, camera settings, camera file name and number, etc.), plus a pointer 
or set of directions to the storage location where the original image file is 
located (a folder on an internal hard drive or an external storage medium 
such as an external hard drive, CD, or DVD).  Since Organizer doesn’t 
actually import a copy of the source file, Organizer calls the acquisition 
command “Get Photos” rather than the more typical “Import”. 
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• Copying to Hard Drive: The Get Photos screen for Organizer lets you 
specify a hard drive location for copying the image files from your camera 
memory card as part of the process of adding their thumbnails.  If you fail 
to use this option to copy your camera memory card files when you get 
their thumbnails into Organizer (or make copies at some other time before 
you erase the camera memory card), the camera card will continue to 
hold the only full source files for those photos, and those files will be 
permanently lost when you erase or reformat the camera card.  That’s 
why using this option to copy camera memory card files to your hard drive 
should be a step in your regular Organizer work flow. 

 

 
 

• Off-Line Files: While the automatic Organizer procedure recognizes 
cameras or camera cards when you connect them to your computer, you’ll 
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probably start off having some older photos already on your hard drive or 
on CD/DVD disks that have not yet been added to your Organizer catalog.  
You can also add those files to the catalog manually with Organizer’s 
File>Get Photos command. 

 
• Changing Image Files or Locations: The consequences of Organizer’s 

file system are extremely important.  So long as you use only Elements to 
make all your changes to image files, including modifying the images and 
changing the file structure or location where the full image files are 
stored, Organizer does a good job of updating to keep track of the current 
files.  But except for using the Elements Editor module, if you make 
changes to any photo file in a procedure that does not start in 
Organizer, or if you use Windows Explorer to change the name or folder 
location of any image file, you may have to separately update the 
Organizer thumbnail and file pointer information (using the Organizer 
File>Reconnect command).  Organizer also “watches” folders with existing 
Organizer thumbnails, and will offer to update itself when it notices a 
change.  If the reconnect process can’t find the full file, Organizer won’t 
be able to deal further with the image.   

 
To avoid these problems, start all file changes in Organizer (or from 
the Elements Editor module), so that Organizer can keep track of the 
changes.   
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• To move or rename files, use the Organizer File menu commands 
File>Move or File>Rename. 

 
 

                                 
 

• To delete an underlying image file you must work outside of 
Elements, using Windows Explorer in My Computer, for example.  
But if that file has previously been indexed in Organizer, you should 
then manually remove it from the Organizer catalog with the 
Organizer Edit> Delete from Catalog command (DEL).  
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• To edit a file in the Elements Editing Module, or in the full 
Photoshop Program (for example, Photoshop CS2) if you have it 
installed on your computer, begin by clicking on the Organizer 
Edit>Go to Standard Edit (to use Elements) or Edit>Edit in 
Photoshop (to use PS CS2 or another full version of Photoshop).  
These commands also have keyboard shortcuts (Ctrl-I or Ctrl-H), or 
can be clicked on from the drop-down Edit icon menu at the top of 
your Organizer screen. 
 
Because of the integration between the Elements Organizer and 
Editor modules, you can also start making edit changes directly 
from Editor, so long as you check the Include in the Organizer 
option in the Save or Save As dialog boxes. 
 

                    

 
 

• If you want to edit an image file using some other graphics-editing 
program (for example, Corel Painter IX), Organizer can keep track 
of those changes also, provided that you open the editing program 
from the Organizer.  First you must add the outside program to the 
Organizer editor list by naming it in Edit>Preferences>Editing>Use 
a Supplementary Editing Application.  From then on, simply select a 
file in Organizer and open the outside editing program by clicking 
on it in the Organizer Edit menu or from the drop-down Edit icon 
menu at the top of your screen. 
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3. Arranging Images in the Elements Organizer 
 
Now that we’ve explored how Organizer actually works and how to include and 
update image thumbnails in the Organizer system, let’s take a look at how to 
arrange those thumbnails in the Organizer screen. 
 

• Simplify Folder Structure or Not? When you connect your camera or 
card reader to your computer, Organizer’s Get Photos panel allows you to 
designate the location and folder on your hard drive where you want to 
copy those images.   

 
Because Organizer permits easy photo searching with keyword tagging 
and date searching, Adobe claims as an advantage for its program that 
you no longer have to take the time to save your images in an elaborate 
folder and subfolder arrangement in your hard drive.  You may choose to 
keep all your photos in a single My Documents\My Pictures folder, 
especially if you don’t take many photos, but I recommend that you 
continue to use at least a modified folder and subfolder structure for your 
image files.  Folders offer several important advantages:   
 

o Placing all your photos in a single folder really only works well if 
you know that you’ll always put in the time and effort to add search 
tags (Organizer’s graphical system of keywords) to all of your 
photos as soon as you add the image files to Organizer.  Since this 
article was originally scheduled for publication last month, I know a 
little bit about the dangers of presuming that things will always be 
done timely.  Professional photography studios can hire staff people 
or part-time interns to handle indexing tasks on time, but non-
professionals need to plan more realistically.  A logical file structure 
can help you find images even if you haven’t yet gotten around to 
applying search tags or keywords. 

  
o Keeping image files in a file folder structure allows you to access 

groups of image files without using Organizer.  This can facilitate 
making and accessing your storage or back-up CD/DVDs, or 
sharing them with family and friends.   

 
o If you’ve already taken and stored a lot of photos, they’re probably 

already in a folder structure, so it’s easy to import them into 
Organizer without immediately having to add keywords for 
indexing.   
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o And if you store your images in a logical folder structure, you get to 
use Organizer’s Folder Location thumbnail viewing option 
(discussed below). With the Folder Location arrangement, you can 
always click in the standard folder tree panel at the left of the 
Organizer screen so that you’re immediately looking at the panel of 
thumbnails you’re interested in, without a lot of scrolling, and 
without having to remember any dates.   

 
 
So instead of storing all your photos in a 
single My Pictures folder, consider 
making a special subfolder for each 
major trip or other event where you’ve 
taken many photos.  Place the r
miscellaneous images into a single folde
for each year (or month, if you have 
more than a few miscellaneo
 

emaining 
r 

us photos). 

 
• Thumbnail Arrangement: The Elements Organizer lets you order the 

te and 

 
If you choose to arrange your thumbnails by date and time, you can 

p or 

 
 see 

 
 
 
 
 
 
 
 
 
 

thumbnails in several ways, using a menu at the bottom-left of your 
screen.  If you don’t use subfolders to identify your images, you’ll 
probably want to arrange the Organizer thumbnails according to da
time.  As already mentioned, this really relies on you to promptly tag the 
images for keyword searching, which will be discussed in detail in Part 
Three of this Guide.   

specify the sorting direction (placing the latest photos either at the to
at the bottom).  Placing the latest thumbnails at the top causes the 
Organizer to open with a display of your most recent photos.  This is
efficient because it avoids having to move through multiple screens to
what you’re most likely to be interested in – your most recent images.  
However, you may find that it feels more logical to arrange your 
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thumbnails with the older (first) images at the top, so they appea
chronological order.  Try both methods and decide which you prefer. 

r in 

 
Note that using the drop-down menu at the bottom-left of your screen to 

 you prefer to arrange your photos 

 

f
ft 

• Thumbnail Size: Another display adj stment appears as a slider at the 

 a 
t 

 my 

hich 

set the Organizer to display thumbnails according to “Date (Oldest First)” 
or “Date (Newest First)” is not the same thing as the “Date View” icon at 
the top-right of your screen.  The Date View icon calls up a Calendar 
display, which you’ll find useful only for special circumstances. 

 
If
under a logical folder structure as 
recommended earlier (for example,
My Documents\My Pictures\Travel\ 
China 05), choose Folder Location 
rom the thumbnail arrangement 

drop-down menu at the bottom-le
of your Organizer screen.  
 
u

bottom right of your Organizer screen.  You can click or drag the size 
slider to change the size of the thumbnails so that they’re displayed at
size that’s comfortable for you.  You can even click on the icon at the righ
of the slider to get an immediate large single-photo view of a selected 
thumbnail, or click on the icon at the left of the slider to display the 
maximum number of very small thumbnails for quick navigation.  (On
screen, if I close the Organizer Bin (the right-hand panel showing tags or 
collections) by clicking at the bottom-right of the screen, the smallest 
thumbnail view will display approximately 70 thumbnails per screen, w
is nice in theory, but not large enough to be generally useful.) 
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The smallest thumbnails 

 
 

           
The largest thumbnail 
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• Your Default Organizer Workspace: The Organizer workspace 
settings in effect when you close the module will become your default for 
later sessions, so it may be helpful to reverse any special changes you’ve 
made to the settings before you close Organizer. 

 
Now that you have explored the underlying workings of Organizer, and how to 
arrange your thumbnail images for maximum convenience, please look for the 
next issue of your the Digital Photography Tutor Members Bulletin, scheduled 
soon.  That will contain the concluding Part Three of this Quick Guide to Vacation 
Photos.  There you’ll be guided through the actual Organizer workflow steps for 
using the Photoshop Elements 3.0 or 4.0 Organizer to save, backup, rename, 
organize and index all your photos so that you’ll always be able to find the ones 
you want to adjust, share, and print. 
 
 
 
 
Meanwhile, if you have any particular digital photography questions, please 
remember that as a registered buyer of the Digital Photography Tutor eBook, 
all you have to do is email me at JerryRabow@DigitalPhotographyTutor.com to 
receive a personal reply.  The question and answer may even be able to help 
others as an anonymous posting on my Ask the Tutor page at 
www.DigitalPhotographyTutor.com. 
 
And be sure to visit the website periodically to keep up with the latest 
developments and catch the latest tips and tutorials for your digital 
photography.  
 

Jerry Rabow 
The Digital Photography Tutor 

  
 
 
Copyright 2005 by Jerry Rabow.  All Rights Reserved.  All comments are the opinion of the 
author.  Please do not use any text or images in your own projects or post on any website 
without advance written approval.  All names and trademarks are the property of their respective 
owners.  All Rights Reserved. 
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